50% OFF - The Complete TDD course
Are you ready to master clean code, testing and Test-Driven Development (TDD)?
I recently launched a complete TDD course containing everything you need to craft high-quality software.
Now there is a 50% OFF for the course
Get instant access by clicking here.
Motivation
Booleans are one of the simplest constructs in programming, yet it can often make code more complex and less straightforward. Booleans have only two possible values (true or false), yet I often see them poorly named and misused in many codebases.
In today’s article, I’ve gathered 4 naming and 2 usage tips relating to booleans. By applying these principles, you can avoid common pitfalls and Craft Better Software.
1️⃣ Avoid Negative Names
Negative boolean variables lead to double negatives, making your code harder to read and understand.
❌ if (!isNotActive)
✅ if (isActive)
The same happens in natural language: you use only one negative, because a double negative is just an affirmative sentence. Why would it be different with code?
You should write code that reads like natural language.
2️⃣ Use Adjectives
Don't use verbs or nouns in your boolean variable names. Booleans represent states, so they should be named with adjectives or short descriptive phrases instead.
❌ if (sendEvent)
✅ if (eventIsSent)
3️⃣ Use Present Tense
Boolean variables should describe the current state rather than past states. Using past or perfect tenses adds noise, making boolean variables wordy and less concise.
❌ if (hasBeenPaid)
✅ if (isPaid)
4️⃣ Use Is
/Has
/Should
/Can
Prefixes
One of my favorite tricks when naming booleans is to use prefixes. Consider using the following:
is – for states (e.g., isActive)
has – for ownership (e.g., hasSubscription)
should – for expected behavior (e.g., shouldRetry)
can – for capabilities (e.g., canEdit)
5️⃣ Avoid Boolean As Parameters
Using boolean flags in function parameters can be confusing and difficult to review. Instead, use enums to make your code self-documenting.
❌ Bad Examples:
bookFlight(customer, true);
bookFlight(customer, false);
✅ Good Examples:
bookFlight(customer, Discount.Applied);
bookFlight(customer, Discount.NotApplied);
Enums also help make your code open for changes. By extending the enum type with a new value, you can easily add new functionality without breaking the API.
6️⃣ Reduce Nesting With a Return Early
Using many IF-ELSE statements with booleans can easily lead to unreadable code. Avoid using nested IF statements.
Instead, invert the conditions and use guard clauses. It will make your code easier to follow. As a bonus, you will get rid of the ELSE statements:
Conclusion
Booleans are one of the most frequently used variable types. And if they are used right, they can greatly improve code quality.
To improve code quality further, Test-Driven Development is my favorite tool. If you want to master TDD, check out my recently launched complete TDD course, which includes:
The fundamentals of Test-Driven Development
Three real-world TDD examples in C#, TypeScript and Rust
The two schools of testing with the 5 types of mocks
Using TDD to design high-quality software
Testing legacy code
Refactoring best practices
Good advice. I've seen most of these, but had not seen the tip on "Use Is/Has/Should/Can Prefixes" with booleans. I'm experienced enough now to do that automatically, but it is good to see it spelled out regardless. It is certainly of benefit to learners.
Great article: simple to understand and apply the recommendations next